81 words

Stacktrace in Explorer when running query

#1
2016-12-05 13:54

Hello,

whenever I run a query in Explorer I get the following stacktrace (cf. attached file).

My environment is:

macOS Sierra 10.12.1 with java version "1.8.0_112"

Is there anything I can do to fix this?

Many thanks in advance

Alex

alexweirig
alexweirig's picture
Joined on 2016-11-30
User Post #5
#2
2016-12-05 14:09

The stack trace indicates a problem in mapping entity fields to an Explorer view.

Try to remove (or move) the file ~/.objectdb/explorer.xml (which may contain obsolete Explorer view settings) and then restart the Explorer.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
support
support's picture
Joined on 2010-05-03
User Post #2,668
#3
2016-12-05 14:55

Hello,

that solved the problem, works like a charm now.

Thank you very much.

Alex

alexweirig
alexweirig's picture
Joined on 2016-11-30
User Post #6

Post Reply

Please read carefully the posting instructions - before posting to the ObjectDB website.

  • You may have to disable pop up blocking in order to use the toolbar (e.g. in Chrome).
  • Use ctrl + right click to open the browser context menu in the editing area (e.g. for using a browser spell checker).
  • To insert formatted lines (e.g. Java code, stack trace) - select a style in the toolbar and then insert the text in the new created block.
  • Avoid overflow of published source code examples by breaking long lines.
  • You may mark in paragraph code words (e.g. class names) with the code style (can be applied by ctrl + D).
  • Long stack traces (> 50 lines) and complex source examples (> 100 lines) should be posted as attachments.
Attachments:
Maximum file size: 32 MB
Cancel