245 words

Java fails to run when using JMX Remote + ODB agent

#1
2011-07-26 10:52

Hi,

When using both JMX Remote and ODB as agent, there is a problem to run JVM at all. All this is on Debian linux with two different JVM's. Let me show you some logs from console:

- pure java 

homplex@homplex01:~$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.7) (6b18-1.8.7-2~squeeze1)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)

- pure java + agent

homplex@homplex01:~$ java -javaagent:/home/homplex/objectdb/objectdb.jar -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.7) (6b18-1.8.7-2~squeeze1)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)

- pure java + JMX Remote

homplex@homplex01:~$ java -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=16969 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=fals -versionjava version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.7) (6b18-1.8.7-2~squeeze1)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)

- agent + remote

homplex@homplex01:~$ java -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=16969 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=fals -javaagent:/home/homplex/objectdb/objectdb.jar -version
homplex@homplex01:~$

As you can see, jam dies right at the start. And the same for SUN Jvm:

- pure java

homplex@homplex01:~$ java -versionjava version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
homplex@homplex01:~$

- java with agent

homplex@homplex01:~$ java -javaagent:/home/homplex/objectdb/objectdb.jar -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
homplex@homplex01:~$

- java with remoting

homplex@homplex01:~$ java -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=16969 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=fals -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
homplex@homplex01:~$

- remoting + agent

homplex@homplex01:~$ java -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=16969 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=fals -javaagent:/home/homplex/objectdb/objectdb.jar -version
homplex@homplex01:~$

The strange thing is, that every thing works fine on MacOS x. I didn't try this on Windows. How can I help you debug this issue?

 

lwalkowski
lwalkowski's picture
Joined on 2010-08-25
User Post #46
#2
2011-07-31 15:55

Please try build 2.2.8_09 that should fix it.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
support
support's picture
Joined on 2010-05-03
User Post #489
#3
2011-08-01 17:55

Thanks, new version works fine.

lwalkowski
lwalkowski's picture
Joined on 2010-08-25
User Post #47

Post Reply

Please read carefully the posting instructions - before posting to the ObjectDB website.

  • You may have to disable pop up blocking in order to use the toolbar (e.g. in Chrome).
  • Use ctrl + right click to open the browser context menu in the editing area (e.g. for using a browser spell checker).
  • To insert formatted lines (e.g. Java code, stack trace) - select a style in the toolbar and then insert the text in the new created block.
  • Avoid overflow of published source code examples by breaking long lines.
  • You may mark in paragraph code words (e.g. class names) with the code style (can be applied by ctrl + D).
  • Long stack traces (> 50 lines) and complex source examples (> 100 lines) should be posted as attachments.
Attachments:
Maximum file size: 32 MB
Cancel