About Maven

forum_thread

Eclipse plugin problem (using ObjectDB as a separate bundle)

Hello support, I have seen multiple attempts to correct similar errors as in the title above - the latest in the 2.2.8.01 release of objectDb. However I still get this error.   Here is my scenario (Groovy 1.8 and Eclipse 3.6) used. I have a com.epimss.lab.data.toxicology.TherapeauticDrugScreenRqst. Nested in this class are the following two classes: com.epimss.lab.data.misc.OtherRqst and com.epimss.lab.data.misc.RequestDateAndNumber. ... Select "Group items by category", then deselect "Maven integration (optional)" see the "Groovy attachment below"   ...

 
forum_thread

Problem upgrading

Hello! We are trying to upgrade from 2.6.3 to 2.6.6. Now our application throws an exception. It's generating endless log files. I had to turn up Xmx to even see it before the JVM crashes. (Our web framework tried to show the exception on the client) I did a full rebuild of the project. It's using the right version of the enhancer. There are no code errors. If I change everything back to 2.6.3 it starts to work again. Any ideas? Best Regards   Here's a part of the output: ... exactly what I did. I even delete my whole local maven repository to force a clean install of every artifact. That's ...

 
forum_thread

InternalError on multiple AND and JOIN Query

Hi, Using objectdb 2.2.8_06. Running the following query: SELECT DISTINCT $1 FROM CDI $1 JOIN $1.contactDetails $2 JOIN $2.addresses $3 JOIN $3.attributeList $4 JOIN $2.phoneNumbers $5 JOIN $5.attributeList $6 WHERE ((($4.name='suburb') AND ($4.valueAsString='Los Angeles')) AND (($6.name='areacode') AND ($6.valueAsString='310'))) Getting: ... [INFO] For more information, run Maven with the -e switch [INFO] ...

 
forum_thread

Cannot cast com.objectdb.jpa.Provider to PersistenceProvider

Hi! I'm trying to get ObjectDB 2.5.1_1 work with stable Glassfish 4 in a Java EE 7 NetBeans project. objectdb.jar is added into GF's classpath (domains\domain1\lib\ext folder). Any help, please?... Thanks! Here it is the persistence.xml config: ... /lib/ext. I know the tutorial, but I'm using Maven. WEB-INF/lib worked also. Thanks for help. Best wishes! ...