About check

forum_thread

Performance tuning, best practices

we have a system where we serve from a host process around 200 clients connected via webSockets (Jetty). The core process is running on a dedicated Windows 2012 server with 16 GByte RAM and 8 processor cores.  What is strange for us is that max 20% of the cpu resources are used and the IO subsystem is at maximum 30% of activity under heavy load but database queries are let's say not at the speed we would expect. We have currently 20.000.000 objects in the database, our configuration settings are: ... path="." mode="write" />   <locking version-check="true" />   <processing cache="2048mb" max-threads="48" ... query) is slow also for a single user? i.e. can you check if the performance issue is due to load of several concurrent clients, or ...

 
forum_thread

Failed to write the value of field using reflection (error 363) on LAZY fetch

Hi There I am using ObjectDB 2.6.3. I get the following Exception when I try to read my entities with a query where I have set to use LAZY initalization. It fails when it tries to set a 1:n member (e.g. a Modell has several Artikels) . When I remove the LAZY hint on the query execution it works. Any hints why this can happen? The Mapping of class Modell and its member: ... entities will not be detached on exiting a method, please check Spring Framework documentation and their Forum. ...

 
forum_thread

PersistenceManager.getObjectsById(Collection,boolean) throwing JDOException

I have a call to getObjectsById(Collection,boolean) that is throwing a JDOException the first time I'm attempting to retrieve an object. If I try again, then the second request succeeds. Any idea why this might occur? We're using ObjectDB 2.2.4_02. The collection being passed in is a HashSet<Object> containing a single oid object (the method is written to support multiple objects, but it seems to only be failing irregularly when only a single oid is present). I'm passing false in as the verification argument.... is not found is the real problem. Could you please check the log files? You may find the complete stack trace. ...

 
issue

Blocked by find

I have a container object which wraps an objectdb database. There is a "putIfAbsent(String id, Object obj)" method which is synchronized and attempts to load an object by id using the EntityManager "find" method. If nothing is returned from the db the passed object is persisted to the db. I have 5 threads which use this method. In a run today one of the threads seems to have got stuck somewhere in the find. The thread dump looks like: Bug Version: Priority: High Status: Fixed Replies: 23 Type:  Bug ...

 
forum_thread

InternalError on multiple AND and JOIN Query

Hi, Using objectdb 2.2.8_06. Running the following query: SELECT DISTINCT $1 FROM CDI $1 JOIN $1.contactDetails $2 JOIN $2.addresses $3 JOIN $3.attributeList $4 JOIN $2.phoneNumbers $5 JOIN $5.attributeList $6 WHERE ((($4.name='suburb') AND ($4.valueAsString='Los Angeles')) AND (($6.name='areacode') AND ($6.valueAsString='310'))) Getting: ... 23:30 Please check the Pom in the version of test I gave you. I have now run it with 2.28_07 ...

 
forum_thread

ObjectDB within a resource adapter module and Java EE Connector Architecture

Has anybody managed to use ObjectDB in a resource adapter module in accordance with the Java EE Connector Architecture so that it may be packaged separately from (but used by components of) an EJB Module after the pattern of the classic EAR File structure as illustrated in the Java EE 7 tutorial in Figure 5-1 EAR File Structure ? ... $objectdb in the url) with a value from a system property. Check what can work for you and if you define a simple feature request we may ...

 
forum_thread

Remove not working

Hello! We have a strange problem. #1 2015-12-15 17:14 Hello! We have a strange problem. Caused by: com.objectdb.o._EntityNotFoundException: Entity is not ...

 
forum_thread

Missing Data on Retrieval (0, null values)

I try  to export all Objects in an Flatfile-Hiearchy (.csv). But only the first exported Table contains all necessary Data. Most of the others  contains all  Object-Rows', but most Values of the Columns are missing. With a  em.clear() inside the Loop, all tables are exported correctly but the Enity-Keys do not match. I can't get the point - what am i doing wrong?   emf = Persistence.createEntityManagerFactory(dbFile); em = emf.createEntityManager(); #1 2016-04-13 07:07 I try  to export all Objects in an Flatfile-Hiearchy (.csv). But only the first exported Table contains ...

 
forum_thread

Performance issues on aggregate query

we are using this aggregate query to collect some data: ... This is strange. It might help to check if the query plan is different with/without  childNodes content ...

 
forum_thread

Query results are not up to date for entities, not primitives

When using the CriteriaBuilder to query, the retrieved list are not refreshed according to the latest updates. But, when using the JPQL Query, the list are refreshed. What is the problem? ... mode = "write" / > <locking version - check = "true" / > <processing cache = "1024mb" max - ...