About client

forum_thread

Problem on JPA Merge Entity.

Hello, I have a problem with the EntityManager.merge() function. I set a property value of an entity (statement) with an other entity (newSingleConstraint). newSingleValue is already persisted. I do this myself (no use of cascade because sometimes the newSingleValue is already in database).   The statement update don't throw exception. And when i try to reload statement the value i have set before is a null value. I check with the Explorer, the statement has a null value on the property and the newSingleValue is present.... Please verify that you switched the server and the client (in pom.xml) to 2.0.5 and that the project was rebuilt and then ...

 
doc

java.lang.RuntimeException

(Exception of java.langException RuntimeException)

 
release

2.2.6

... boxes. Fixed an UPDATE/DELETE query bug in client-server mode. Fixed an ArrayIndexOutOfBoundsException in ... Fixed unexpected  NullPointerException in client server mode. Fixed an exception in AVG query on non ...

 
forum_thread

Activation Issue

Hi, We bought a site license the yesterday. I ran the activation class this morning. That generated the activation key. I took that key as per the instructions, added it to the objectdb.conf inside the jar, and everything was happy. (this was with 2.3.7). However after a reboot I'm now getting the evaluation license restriction message again at compile time (which was I was seeing before putting the activation key in objectdb.conf). I tried upgrading to 2.3.7_02 and updating objectdb.conf with the activation key, but get the same behaviour. ... setting is required on the server side so if you are using client-server and you added it to the client side (the web application) it will not work. You have to run the server ...

 
release

2.2.5

... boxes. Fixed an UPDATE/DELETE query bug in client-server mode. Fixed an ArrayIndexOutOfBoundsException in ... Fixed unexpected  NullPointerException in client server mode. Fixed an exception in AVG query on non ...

 
forum_thread

Eclipse4 RCP - No Persistence provider for EntityManager

Hello, I'm developing an Eclipse4 RCP application which uses ObjectDB and have the following problem after calling Persistence.createEntityManagerFactory("test.odb") : javax.persistence.PersistenceException: No Persistence provider for EntityManager I'm using the latest ObjectDB 2.6.2.b03. It is integrated in our target platform. It is noticed that since 2.6.2.b02 there is no more integrated javax.persistence & javax.transaction. ... the access to the ObjectDB database Plugin project client - uses the OSGi Service - ObjectDB Bundle is set as Dependency ...

 
manual

Database Explorer

Explains how to run and use the ObjectDB object database Explorer to view and manage Java/JPA/JDO objects visually.... a local database file. To open a database in client-server mode select File > Open C/S Connection...  and provide host, port, username and password for a client-server connection. You also have to specify a database path on the ...

 
manual

Database Explorer

Explains how to run and use the ObjectDB object database Explorer to view and manage Java/JPA/JDO objects visually.... a local database file. To open a database in client-server mode select File > Open C/S Connection...  and provide host, port, username and password for a client-server connection. You also have to specify a database path on the ...

 
issue

JPA Composite Key make Object Db throws "Unexpected exception (Error 990)"

Hello Object Db community :) I am using this wonderful library and I caught a strange exception while testing the "composite key" feature in JPA. Let's see what I am doing : @Entity public class Book {     @EmbeddedId BookId id; } @Embeddable Class BookId {     Integer bookIdCountry;     ECountry country; } My BookId contains 2 attributes: One Integer and one enum. ... exception (Error 990) Generated by Java HotSpot(TM) Client VM 1.6.0_32 (on Windows XP 5.1). Please report this error on ...

 
forum_thread

Can't post on your forum

Since yesterday, I can't post on the forum because it always says that I should log in in order to do that. I was already logged in, but, anyway, it appeared as not. I go to log in, then I authenticate, then I'm redirected to the home page, but it still looks that I'm not logged in, so I can't post on the forum. I tried removing the cookies, but nothing. I tried in another browser, but the same. I have new bugs to post, so it's pretty important. ... users and guests are generated by JavaScript / CSS on the client side (based on cookies). This enables better caching, but if there are ...