About true

release

2.4.6

... #78 ). Added support of @Column(unique="true") and equivalent ORM XML ( issue #79 ). Fixed ...

 
issue

Blocked by find

I have a container object which wraps an objectdb database. There is a "putIfAbsent(String id, Object obj)" method which is synchronized and attempts to load an object by id using the EntityManager "find" method. If nothing is returned from the db the passed object is persisted to the db. I have 5 threads which use this method. In a run today one of the threads seems to have got stuck somewhere in the find. The thread dump looks like: ... "objectdb.page.circle" system property set to "true" - a page circle will be detected as soon as it is created and related ...

 
issue

ObjectDB can't be activated

Hello, we are trying to activate objectdb on a virutalized debian 7 server, but do not have any success. Steps we made to activate the server: ... == displayName = venet0 name = venet0 subInterfaces = true hardwareAddress = null == NetworkInterface == displayName ...

 
issue

Unexpected Exception during commit

I'm testing code that otherwise has been working with a clean database. I have seen several examples of the following exception. It never seems to happen in the same place twice, though. If you can give me a hint as to what would internally cause this, I'll try to reproduce it. Carl   ... in order to access or alter even a single item. Is that true? In cases where I have a large number of entities that are not used as a ...

 
issue

Unexpected error when loading all entity instance

Hi, when going through all entity instance to find orphaned entries we get the exception: ... Recovery is enabled <recovery enabled="true" sync="false" path="." max="128mb"/> Is there another way for ...

 
release

2.4.5

... #78 ). Added support of @Column(unique="true") and equivalent ORM XML ( issue #79 ). Fixed ...

 
release

2.4.3

... #78 ). Added support of @Column(unique="true") and equivalent ORM XML ( issue #79 ). Fixed ...

 
release

2.4.4

... #78 ). Added support of @Column(unique="true") and equivalent ORM XML ( issue #79 ). Fixed ...

 
forum_thread

Replication error - parsing objectdb config

I'm trying to replicate a database using the following config: <server>   <connection port="6136" max="100" />   <data path="$objectdb/db-files" />   <replication url="objectdb://localhost:6126/DEV1/NewMessagePipe.odb;user=admin;password=admin" /> </server> ... is enabled: <recording enabled = "true" sync = "false" path = "." mode = "write" /> ...

 
release

2.4.2

... #78 ). Added support of @Column(unique="true") and equivalent ORM XML ( issue #79 ). Fixed ...