Home » Support » Forum » Object Relations Error after Schema Change

Object Relations Error after Schema Change

#1

Hi we have a problem with relations in OBjectDB 2.4.6, the problem occured after we changed relations in few clases. Specificaly we deleted relation pointing to one class and created new relation to third class.

If we restart both ObjectDB and Jboss everything works fine for a short period.

Attached is a ObjectDB error message.

Kind regards.

#2

This could be the result of using more than one version of an entity class concurrently.

When you restart the server everything works well for awhile, until a user that still has the old version of the class accesses the database.

Please verify that the same versions of all the entity classes are used by all the parts of your application.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
#3

Hi, we only use one entity class version.  Attached second log file.
Problem occurs when we create a new entry in the class we have changed the relation.
Quote from the log “08:44:09,440 ERROR [stderr] (http--10.10.10.60-8080-3) Failed to write the value of field field pbdmodel.impl.UserImpl.userRazgovor using reflection (error 363)”

Is there a way (tool, utility, script) to migrate data from one ObjectDB database to another ObjectDB database, we think starting with a new DB would help resolve this.

We would apreciate promt reply since we go live in 3 days. 

Thanks in advance.

Regards.

#4

Could you please check the database with the ObjectDB Doctor and post the output?

In addition, you can try migrating the data to a new database automatically by running the Doctor in repair mode.

If this doesn't help and you can upload the database (possibly privately using a support ticket), we may be able to find the problem and suggest a fix.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
#5

Hi, 

we tried reparing the database with Doctor, tried changing the names of classes, nothing helps.

When runing DB check nothing significant comes out.

We will atach our DB file in a separate post.

Regards.

 

#6

The database looks healthy and nothing wrong was found in the 3 classes that you mentioned.

Could you please try the last ObjectDB version (2.5.3_03) to verify that this is not an issue that has already been fixed?

If you still get the exception, can you provide an application that can cause the exception? Source code is not required, but it should include all the required classes, so we will be able to run it.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply

To post a reply and/or subscribe to update notifications - please login