Replication not working anymore

#1

Hello!

I upgraded my ODB Version to 2.5.4 to get rid of some bugs. Now i tried to start my replica server.
It starts fine and then crashes after a few seconds with the following exception:

java.lang.NullPointerException                                                                                           
at com.objectdb.o.RPR.u(RPR.java:248)
at com.objectdb.o.RPR.<init>(RPR.java:112)
at com.objectdb.o.SMR.S(SMR.java:645)
at com.objectdb.o.SMR.n(SMR.java:162)
at com.objectdb.o.TOL.run(TOL.java:116)
at com.objectdb.Server.runCommand(Server.java:198)
at com.objectdb.Server.run(Server.java:103)
at com.objectdb.Server.main(Server.java:62)

What can be wrong?

Regards

Ralph

#2

We tried using replication with version 2.5.4, but no exception was thrown, so unfortunately we don't know yet how exactly to reproduce this issue.

Could you please provide step by step instructions for reproducing this new issue?

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
#3

I got this stack trace when enabling recording on slave server and restarting it. It converts my *.odb to *.odb_nonclosed

#4

Sorry for the late reply. I got it to work again by starting over. I deleted the whole ObjectDB folder. Extracted it from the downloaded zip. Copied the database onto the master machine. Configured all and it worked.
I don't know what went wrong the first place. I did not do anything different the first time.

#5

Thanks for the update. Hope it will keep working now.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply

To post a reply and/or subscribe to update notifications - please login