Fast Object Database for Java - with JPA/JDO support

Running the Activator requires Java 6 or above.

#1

Objectdb version 2.8.3:

Java version is current:

java -version
openjdk version "11.0.9.1" 2020-11-04
OpenJDK Runtime Environment 18.9 (build 11.0.9.1+1)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.9.1+1, mixed mode)
 

But activation complains:

java -classpath objectdb.jar com.objectdb.Activator

ObjectDB Activator [version 2.8.3]
Copyright (c) 2020, ObjectDB Software. All rights reserved.

Running the Activator requires Java 6 or above.
 

 

 

 

#2

Note: the Activator does work with: 11.0.9-zulu

openjdk version "11.0.9" 2020-10-20 LTS
OpenJDK Runtime Environment Zulu11.43+21-CA (build 11.0.9+11-LTS)
OpenJDK 64-Bit Server VM Zulu11.43+21-CA (build 11.0.9+11-LTS, mixed mode)
 

The problem is with: 11.0.9.open-adpt

#3

Thank you for this report. Build 2.8.3_04 should fix the error.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply