Fast Object Database for Java - with JPA/JDO support

ObjectDb JDK8-11 support

#1

Currently we are using ObjectDb 2.6.1 and JDK7, but next 2 month all projects will be moved to JDK8 and JDK11. Could you confirm which stable ObjectDb versions should we use for

  1. JDK8
  2. JDK11

There is no any information about it in latest ObjectDb documentation.

Harman Ltd.
#2

The recommended version is 2.8.4. Version 2.6.1 is 5 years old, and many improvements as well as bug fixes (some are critical) have been applied since then. Extensive testing of your applications with the new version is highly recommended, to verify that differences between the ObjectDB versions do not break anything.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply