Home » Support » Forum » Replication Error

Replication Error

#1

Hello!

I try to get a replication setup working on two test servers. So i copied my test database to one of them, enabled recording and started odb. The dbname.odr folder got created so i think everything is ok. Afterwards i added the replication tag to the configuration of the second server and started it.

The second server starts complaining instantly with the following Exception:

com.objectdb.o.UserException: Failed to synchronize replicated database
at com.objectdb.o.MSG.d(MSG.java:61)
at com.objectdb.o.RPT.d(RPT.java:97)
at com.objectdb.o.RPT.<init>(RPT.java:65)
at com.objectdb.o.SHN.aw(SHN.java:704)
at com.objectdb.o.SHN.K(SHN.java:203)
at com.objectdb.o.HND.run(HND.java:133)
at java.lang.Thread.run(Thread.java:722)

This message is repeated every few seconds.

I already tried to fix the db with the doctor. No error is found.

I use the latest version of ObjectDB. (2.3.6_16)

Do i miss something or is this a bug?

Regards
Ralph

#2

You should try copying the initial database to both servers.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
#3

Thank you! Now it works.

Why do i have to do this manually? The manual says that it gets copied automatically.

#4

Yes you are right, the documentation was misleading (it was fixed now).

The database is automatically copied from the master to the slave only if full recording is available starting transaction #1. If recording is enabled for an existing database, currently the database is not copied automatically (but this should be improved in future versions).

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply

To post a reply and/or subscribe to update notifications - please login