Home » Support » Forum » Error when trying to open the Explorer (failed to find Java VM)

Error when trying to open the Explorer (failed to find Java VM)

#1

Hi,

I use windows 7 64 bit version.

When I'm trying to open the ObjectdB explorer I get this windows error:

"Failed to find Java VM".

 

What is the problem?

Thanks, Dreckguy
#2

Have you tried both explorer.exe and explorer-b.exe?

Can you write it from the console:

> java -jar explorer.jar
ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)
#3

On windows:

both explorer.exe and explorer-b.exe cause the same error.

 

On console:

 By trying explorer.exe I get the following:

[info] Module INI: C:\dbs\objectdb-2.5.3\bin\explorer.ini
[info] Module Dir: C:\dbs\objectdb-2.5.3\bin\
[info] INI Dir: C:\dbs\objectdb-2.5.3\bin\
[err] Failed to find Java VM. 

and the windows startup error is shown

By trying explorer-b.exe I get just the windows startup error

 

By trying java -jar explorer.jar the explorer opens as supposed.

Both on console and on windows using explorer.jar works as supposed.

so after finding the jar file start everything needed it won't cause a problem but still worth reporting.

 

 

Thanks, Dreckguy
#4

Thank you for this report.

ObjectDB is packed with two different Explorer exe wrappers for Windows, because there were issues with each of them on some systems. Following your reports we tried both of them on Windows 7 64 bit and they worked for us properly, so the exact cause of this reported problem on your computer is unclear.

Anyway, in this situation using the jar directly as you suggested could be a good workaround.

ObjectDB Support
ObjectDB - Fast Object Database for Java (JPA/JDO)

Post Reply

To post a reply and/or subscribe to update notifications - please login